is the survey compatible with all internet browsers?

0

is the survey compatible with all internet browsers?

Mary L (Moderator) answered
    0

    You can read about system requirements for SurveyGizmo by following the link below.

    https://help.surveygizmo.com/help/surveygizmo-system-requirements

    Quick answer is that they recommend using the latest versions of Google Chrome, Mozilla Firefox, and Microsoft Internet Explorer. If you are on a mobile device, they recommend up-to-date versions of built-in mobile browsers such as SafariAndroid, and IE for Mobile

    Mary L (Moderator) answered
      ×

      Login

      Question stats

      • Active
      • Views852 times
      • Answers1 answer
      • Followers1 follower