Reporting “Advanced Filter” Issue/Help?

0

Hi There,

I am trying to use the Advanced Filter on a report to remove our internal responses, but keep our customer responses. All internal responses use email addresses that end in@fred .com.au or@fred .com – to do this I have set the Advanced filter up as follows:  

 

However, it doesn’t quite seem to work as expected – and seems to include@fred .com.au and@fred .com still in the responses list.

 

However if I remove the@fred .com (and keep only @fred.com.au) in the Advanced Filter it works ‘better’ but still leaves an@fred .com response that I wish to remove?

 

Any help appreciated?

Thanks,

Nicole

Nicole Sorbell answered
    1

    Thanks for this – good to know for future.

    In this instance I ended up getting around it by using 2x Question Answer (email) does not contain options instead.

    Nicole

    Nicole Sorbell answered
      2
      IS 2.20K Rep.

      You just need to change the OR between your tests to an AND.

      Right now the response is included if it does not match the first pattern or it does not match the second pattern. only a response the matches both would be suppressed.

      Changing to an AND, a response is included if it does not match either pattern.

      Logic with negatives (e.g. does not contain) can often be confusing.

      IS answered
        ×

        Login

        Question stats

        • Active
        • Views1779 times
        • Answers2 answers
        • Followers1 follower