[Notice] Survey-Taking Browser Support

0

In a continued effort to provide a secure survey taking experience, SurveyGizmo will no longer be supporting the following browser versions for survey-taking:

  • Google Chrome prior to version 27 (2013)
  • Opera prior to version 17 (2013)
  • Mozilla Firefox prior to version 27 (2013)
  • Apple Safari prior to version 9 (2015)
  • Android prior to version 5 (2014)

This change is expected to go into effect on the morning of Thursday, July 13 (Mountain Time). This post will be updated once the change is in place.

UPDATE (Friday, July 14): We are continuing to work on this implementation. Please contact our Support Team with any questions or concerns!

Best regards,

The SurveyGizmo Team

Admin - SurveyGizmo edited question
    ×

    Login

    Question stats

    • Active
    • Views189 times
    • Answers0 answers
    • Followers1 follower