Merge Codes does not work

1

Hi,

 

I created a campaign and added these codes:

 

<p>session: [survey(“session id”)]<br />
id: [survey(“id”)]<br />
messageid: [invite(“messageid”)]<br />
guid: [contact(“guid”)]</p>

 

and this is what I see in the test email

session: [survey(“session id”)]
id: [survey(“id”)]
messageid: [invite(“messageid”)]
guid: [contact(“guid”)]

 

also I used this

 

<a href=”http://www.yurduminsani.com/pages/front/survey_start.aspx?guid=[contact(“guid”)]”>Click Here to Start the Survey [contact(“guid”)]</a><br />

 

and I get this:

 

Click Here to Start the Survey [contact(“guid”)]

 

with html:

<a href=”http://www.yurduminsani.com/pages/front/survey_start.aspx?guid=[contact(“guid”)]”>Click Here to Start the Survey [contact(“guid”)]</a><br />

 

also, from source code, I cannot insert codes from drop down after selecting source!!! When I select an item from drop down, it is not inserted into html source, I need to type it manually…

 

So, what am I doing wrong? Nothing seems to work here!

 

Thanks…

 

Community Admin answered
    0

    now, another issue :)

     

    how can I pass a custom variable in my contact us in the survey end url

     

    I tried

     

    Static Value (use default) = rid

    Variable Name = rid

    Default Value (opt) = [contact(“rid”)]

     

    and this is what I get :)

     

    www.mydomain.com/survey_end.aspx?rid=%5Bcontact%28%22rid%22%29%5D

     

    also tried

     

    URL Variable = rid

    Variable Name = [contact(“rid”)]

    Default Value (opt) = 

     

    None works! Not sure why all these are impossible to achieve, it should be straightforward!

     

    All I want here is pass some filed from my contact list in the redirect url…

    admin answered
      0

      Hi Again,

       

      now I am trying to pass a custom field from my contact list in the redirect url

       

      I tried multiple options

      Post Survey Actions: Redirect to a URL: http://yourdomain.com

       

      Here:

      I tried different options “Fields To Pass (optional)” and tried “URL Variable” & “Static Value (use default)” with “[contact(“rid”)]” in the value or variable name etc… all I got is this:

       

      http://www.mydomain.com/?rid=%5Bcontact%28%22rid%22%29%5D

       

      Not sure why I am having so much difficulties here! It should be very simple and straight forward!

       

      Thanks…

      admin answered
        0

        @Admin : It sounds like you’re trying to do a pretty advanced customization. I would reach out to our support team via chat or email with these questions!

        Community Admin answered
          ×

          Login

          Question stats

          • Active
          • Views23214 times
          • Answers8 answers
          • Followers0 followers