Merge Codes does not work

1

Hi,

 

I created a campaign and added these codes:

 

<p>session: [survey(“session id”)]<br />
id: [survey(“id”)]<br />
messageid: [invite(“messageid”)]<br />
guid: [contact(“guid”)]</p>

 

and this is what I see in the test email

session: [survey(“session id”)]
id: [survey(“id”)]
messageid: [invite(“messageid”)]
guid: [contact(“guid”)]

 

also I used this

 

<a href=”http://www.yurduminsani.com/pages/front/survey_start.aspx?guid=[contact(“guid”)]”>Click Here to Start the Survey [contact(“guid”)]</a><br />

 

and I get this:

 

Click Here to Start the Survey [contact(“guid”)]

 

with html:

<a href=”http://www.yurduminsani.com/pages/front/survey_start.aspx?guid=[contact(“guid”)]”>Click Here to Start the Survey [contact(“guid”)]</a><br />

 

also, from source code, I cannot insert codes from drop down after selecting source!!! When I select an item from drop down, it is not inserted into html source, I need to type it manually…

 

So, what am I doing wrong? Nothing seems to work here!

 

Thanks…

 

Community Admin answered
    0

    @admin: I am sorry for the confusion! You need to be very careful with email invite links. The only link that will work in email campaign invites is the following:

    invite(survey_link)]

    The above merge code will insert all the appropriate information for you to track your respondents. You do not need to add additional merge codes like message and guid as you described above.

    If you’d like additional information about customizing the link text here is a tutorial:

    https://help.surveygizmo.com/help/article/link/customize-email-campaign-link

    I hope this helps!

    Bri
    Documentation Coordinator/Survey Sorceress
    SurveyGizmo Customer Support

    admin commented
      0

      somehow, only this one works correctly

       

      <a href=”[invite(survey_link)]”>Click Here to Start the Survey</a><br />

       

      which renders as:

       

      <A href=”http://survey.yurduminsani.com/s3/328f19/i-0m1Xd-1226246/?sguid=0m1Xd”>Click Here to Start the Survey</A>

       

      other than this, no other options/usages are working… either totally broken or empty…

       

       

      admin answered
        0

        when I send it to a user, this is what I get

         

        <a href=”http://www.yurduminsani.com/pages/front/survey_start.aspx?guid=[contact(“>Click Here to Start the Survey </a>

        <p>session:
        <br />id: <br />messageid: <br />guid: <br />inv: </p>

         

        same as test email… merge codes are not inserted, either blank, or no broken…

        admin answered
          ×

          Login

          Question stats

          • Active
          • Views23277 times
          • Answers8 answers
          • Followers0 followers