E-mail confirmations are no longer providing options checked

0

We use a SG form on our website to automatically qualify organizations or groups to allow or deny flier distribution in our schools… previously the form would email the approval to the requestor with the appropriate boxes checked on the approval letter. The form is still emailed, but the boxes are no longer checked…

I did poke around in the form builder, and I understand the code that IS there, but I am a bit stumped as to what changed… or where the changes happened. Before and after screenshots attached. Oh, and I am new at this, but this one seems extraordinarily perplexing.

 

Previously…

 

Currently… the box is no longer being checked.

 

Jim W (Moderator) answered
    0

    Sorry if I come across as fussy.  I work with several different project teams, and I have learned the hard way that if everyone does not use correct terminology then misunderstandings come up very quickly.

    If I understand correctly, the problem lies in an email that an EMAIL ACTION sends to respondents.  This email uses an image from your graphics library as a background.  In addition, there are two graphic files of check-marks that are superimposed on the background image.  These checkmarks previously appeared at specific points above the background image, but this is no longer happening.

    I am surprised that this ever worked in the first place for three reasons:

    1. Email protocols are relatively primitive.  You have to use HTML coding practices from the 1990s.
    2. The SurveyGizmo email system removes suspect code out of outgoing emails in order to reduce the risk of your email being flagged as spam.
    3. Most respondent’s email system block graphic files in emails until they give permission for them to download.

    I suspect that your problem is in #2, but you would have to contact SurveyGizmo Support about this.  As another SurveyGizmo user, I do not have access to your account to review your files.

    As an alternative to superimposing images over the background, you could use an HTML special character to represent the check-marks. There are several to choose from:

    #9745:
    #9989;
    #10003;
    #10004;

    Place an ampersand character in front of one of these and you get ✔.   These would be less likely to be flagged as a problem and would not be blocked by the respondent’s email client.

    Jim W (Moderator) edited answer
      0

      Jim,

      Thank you for looking at this.

      I need to confess that I am really new to Survey Gizmo, and I am learning the system as fast as I can… so, I do apologize about my loose grasp on the vocabulary.

      This process was working the day I started employment here, but it has one portion that has since stopped working.

      I am not sure of what the survey backend setup originally looked like, and if something was changed, I wouldn’t recognize what changed where, or what to add where, to fix it (although I am motivated to jump in and get this fixed).

      To your questions:

      I said Form, but what I meant was:
      What the end user sees on our website when filling out a survey to request for flier distribution.

      I said Form builder, but what I was talking about was:
      The ‘build’ tab for the survey we have saved that is called “Flier Approval Form”.

      Yes, the survey is embedded on our website and the thank you page sends 2 emails containing the completed approval form to myself and sends a copy to the person who completed the survey/form.

      (I found image files for this approval letter in the ‘Library’ there is a PDF, and 2 jpg images (not sure which ones are being called up, but these are all identical but with different names) – these are basically images of our typed approval letter on our letterhead).

      This is the email that is giving me the problem… It has ‘most of the content’ being correctly populated (Names and Dates, all gathered from responses in the survey/form and are being superimposed over the library image and are being placed correctly in the layout, and are being sent in the above-mentioned emails). The only missing element is that the checkboxes are no being longer checked (with a superimposed checkmark over the library image).

      … I then receive a second email that has a link to download the actual flyer uploaded earlier by the requestor (this is a required step in the survey/form where the person filling out the survey/form must upload their document). This part is working just fine.

      I think merge codes are definitely being used as data from the survey/form is being superimposed over jpg images of a typed approval letter and sent out in email.

      avillescas answered
        0

        If I understand your problem correctly, you have an embedded survey that generates an email that is sent to an applicant.  Evidently there are checkboxes on the email that were once checked, but are no longer checked.

        I will assume that the email is part of an EMAIL ACTION that is placed on the THANK YOU page of the embeded survey.  What is driving the checkboxes to appear (or not)?  What question type are you using for this function?  Are you using merge codes in the email?  Also – can you please clarify what you mean when you use the word ‘form’ and ‘form builder’?

        Jim W (Moderator) answered
          ×

          Login

          Question stats

          • Active
          • Views755 times
          • Answers3 answers
          • Followers1 follower