[Solved] [Known Issue] Some custom scripting variables are throwing syntax errors


We’re currently seeing issues with some common custom scripting variables like %%url and %%value. We’re working on it now and will update this post when it’s fixed. Thanks for your patience!

Patrick - Survey McDuck asked

    Best answer



    We have just released a fix for this issue, and we think we have caught all of the variables causing syntax errors.  :)

    If you are still running into issues, please let us know!

    Jon - The Survey Dude answered

      I put this in a ticket…But here it is for reference if it helpful:

      This used to work:

      %%ar = array();

      foreach(%%ar as %%record)
      %%val = sgapiGetValue(%%record[1]);

      Now it no longer does…This is what is required:

      foreach(%%ar as %%key => %%value)
      %%qid = %%value[1];
      %%val = sgapiGetValue(%%qid);


      Some example scripts don’t work:

      %%format = “Y-m-d H:i:s”;
      %%output .= sgapiDate(%%format);

      The above causes an script syntax error. Switching the variable name %%format to %%fformat allows the script to work.

      jtawil answered
        • Hey jtawil,
          Thanks for posting a workaround, nice job! You shouldn’t need this going forward though, we just released a fix for this one. :)


        Hi guys, this is marked as solved, but still not working for us. Could you advice?

        Latamis answered
          • Hey Latamis,
            Sorry for the delay, we are researching this currently. I’m so sorry things are still down for you. I will update as soon as we have more news.


           Hi guys, we are still seeing the same issue not resolved. Could you please advice?

          Latamis answered

            Any news about this problem?

            Mariano Korendij219365 answered


              Question stats

              • Active
              • Views5399 times
              • Answers5 answers
              • Followers0 followers