[Solved] [Known Issue] Filtering on URL variables in REST API results in error


Note: This is the API return you will currently get – {“result_ok”:false,”code”:400,”message”:”Missing / Incorrect Parameters”}

We are working on fixing this up ASAP!

skernanschloss answered

    Best answer


    Hey Everyone,

    This is all fixed up!  Please let us know if you are still running into issues.  

    -SG Engineers


    • UPDATE – FRIDAY, JUNE 10th – Our second attempt to fix this looks like it is working for most example calls provided.  If you are still running into issues, please let our Support Heroes know as soon as possible!  :)
    Sidus Scientifica AB commented

      Hey guys,

      We are currently researching why these calls aren’t working again.  It seems like potentially another change we made to the API on Friday may have caused these issues to come back to haunt us…

      We will get the Engineers back to work on this issue, and hopefully have a quick resolution!

      Thanks for letting us know everyone.  :)


      Jon - The Survey Dude answered

        Neither v4 and v5 is working

        Admin - SurveyGizmo commented
          • @skernanschloss:

            Thank you for your note, and our apologies for the trouble!

            This is certainly something that our Support Heroes can look into with your example. Please don’t hesitate to reach out to us via either chat or email and we can take a look at this for you!

            Best regards,

            David Domagalski
            Survey Explorer & Documentation Specialist
            SurveyGizmo | http://surveygizmo.com


          Same here. Why can’t we filter on sguid? It’s the only way to asynchronously download response. Is there an update here?

          Lola Gill commented
            • Which version of the API are you using? It might be that this current issue is confined to a specific version (If you are using v5, I might suggest trying v4 as a workaround).

              Hope this helps!


            I am currently experiencing this issue for some surveys. 

            If I try to call the surveyresponse endpoint with correct authentication details then I get the same response message as OP.

            This is happening for all of the example surveyresponse API calls in SurveyGizmo documentation and happens regardless of whether I include filtering or not.

            I have also tried upgrading to v5 of the API, but get the same error.

            Using this format:


            Marybeth commented
              • Hi Chris! FWIW, I just tested a bunch of my own API calls which all appear to be working. Your example format also works with my details. Maybe try double checking your token and secret?


              I can confirm that this is not resolved.


              Does not work. Please look into it again!

              Sidus Scientifica AB answered


                Question stats

                • Active
                • Views14550 times
                • Answers7 answers
                • Followers6 followers