[Solved] [Known Issue] Conditionally Require not working with Custom Group and Contact Form sub-questions.

0

If you are setting subquestions to be required using the “Conditionally Require” feature, this is not currently working.  If you really need to use conditional requirement; for the time being, we recommend using stand alone questions, not group or form questions.

prosper team answered

    Best answer

    0

    Hey everyone,

    Conditionally require should be working in custom group and contact form subquestions now, but do let us know if you continue to see problems with it!

    Patrick - Survey McDuck answered
      0

      I seem to have the same problem.  I have a custom group with several sub-questions, the last of which requires a response (essay/long answer) if certain conditions are met in a former sub-question.  When I try to select the mandatory response conditions for the essay/long answer, the former sub-questions are not available to choose from. 

      SG Admin commented
        • @prosper team,

          Thank you for your post!

          I’m afraid a question inside of a Custom Group cannot be conditionally required based on an earlier question in that same group. This is a limitation of the conditionally require feature.

          In order to conditionally require a question, the question which the requirement is based on will need to be on a prior page.

          Best regards,

          David Domagalski
          Survey Explorer & Documentation Specialist
          SurveyGizmo | http://surveygizmo.com

        0

        I am having the same experience as Abbott.

        SG Admin commented
          • Hi there,

            Thank you for your note!

            When using the conditionally required feature with a Custom Group question, there are two things to consider.

            First, a question inside of a Custom Group cannot be conditionally required based on an earlier question in that same group.

            Second, anytime that you are setting up conditional requirements, the source question must be on a page prior to the question that you are wanting to require.

            I hope this helps clarify!

            David Domagalski
            Survey Explorer & Documentation Specialist
            SurveyGizmo | http://surveygizmo.com

          0

          I have a custom group of questions. If the user answers “No” to the first question, I want to make the second question required. When I go to edit the “Conditionally require this question on previous answers” on the second question, I am NOT able to select any of my previous questions to build the conditional logic. The only options I see are System Data, Geo Tracking, URL Data, and Email Data.

          Please Advise, attached is a screen shot.

          Jon - The Survey Dude commented
            • Hey Abbott!

              We are so sorry you are running into issues with this feature. Please contact our support team and have them investigate what is happening with this feature. We will work with them to get this identified and get a request in place to get this working. :)

              -SG Engineers

            ×

            Login

            Question stats

            • Active
            • Views4695 times
            • Answers4 answers
            • Followers0 followers