Hiding Pie Chart


I’d like to show all charts in my reports except for two, and both of these are pie charts, so obviously I can’t turn off all charts in the report. I only need to hide the pie chart itself, as I’m already hiding the summary table using:

.sg-question-piechart .question-data-summary {

display: none;


How would I also hide the chart itself? 


Sheila Bloom answered


    This is actually an option in the new standard reports.  You can go question by question and turn off and on what you want to show.  First, create a standard report, then click on the pencil next to one of the questions in the report, and scroll about 1/2 way down and  you should see these options.  First, check Override Global Report Styles, then the other options below will appear.    I have not had any luck displaying just one option from the Statistics.  I had tried to show just Sum and Average, and it had trouble unless I selected at least 3 stats to show.  It may be better now as they’ve been releasing fixes every day.


    Hope this helps!

    Sheila Bloom answered

      would just deleting those 2 questions work for you, it sounds like you are already hiding the summary table. You can select the questions to be displayed or not.

      Aura commented
        • Hi Mary, I cannot delete those two questions from the report although I agree it seems like I’m hiding just about everything! The only thing I need displayed is the “Average” value for those questions, and nothing else, which worked out perfectly with that code and hiding the charts. Now that the charts show up, I need a way to hide the charts for just those two questions.



        Question stats

        • Active
        • Views2364 times
        • Answers2 answers
        • Followers1 follower