% of completion does not match the numbers of replies received

0

I ave currently a free membership. I initiated a survey which I sent to 10 people. The system shows that 4 people have completed it, and it is corresponding to 100% response rate. This is in fact only a 40% response rate. Also, more than 4 people have told me they completed the survey but it is not appearing anywhere.

Can someone advise what is going on so that I can have see the full responses?

 

Thank you!

florencedwyer answered
    0

    Thank you, it makes sense, very helpful

    florencedwyer answered
      0
      Lola Gill 6.46K Rep.

      As you mentioned being on a Free Plan, I am assuming that the completion rate that you are referring to is the completion rate found on the Home Page.

      This completion rate is not indicative of how many people have completed the survey out of how many people you sent the survey to. SurveyGizmo does not have a means of determining how many respondents you have sent the survey to (in a Free Plan, the only means of sharing the survey is to copy the link from the Share page and send it out outside of SurveyGizmo).

      The completion rate percentage rather tells you the following:

      Out of all the respondents that have started your survey x % have finished it. So in your case, it would mean that of the 4 respondents that have started your survey, all 4 have finished it (100%).

      I hope this helps clarify!

      Lola Gill answered
        ×

        Login

        Question stats

        • Active
        • Views182 times
        • Answers2 answers
        • Followers1 follower