How do I apply a date format to a question ID?

0

example 1: [question(“value”), id=”29″,format=”Y-m-d”]

example 2: [system(“date”),format=”Y-m-d”]

 

I can’t figure out the syntax to make example 1 work. Example 2 works without a problem!

Alex Walker answered
    0

    Fixed it – here’s the issue: http://screencast.com/t/42CDYy3U8

    Alex Walker answered
      0

      Sorry Alex – I don’t know what to tell you.  It works on my end – http://www.surveygizmo.com/s3/2582651/Sandbox

      How are you collecting the date from the respondent?

      Jim W (Moderator) answered
        0

        Yes, I can verify that there are no loose spaces, but I still get bad syntax. I can’t adjust the date formatting, as I need it to appear in a UK format on the front end, but a different format elsewhere (with dashes too, not slashes)

        Alex Walker answered
          0

          I tried it again on my end.  Make sure that there are no blank space behind the last line of code – there should be a return immediately after each semi-colon.

          If custom-scripting is not going to work for you could you adjust the date validation method you are using – https://help.surveygizmo.com/help/article/link/date#selecting-your-date-format

          Jim W (Moderator) answered
            0

            Ok, the script is clear to me now, so I tried the first test but got a bad syntax error.

             

            http://screencast.com/t/kFNPRbkrZKq

            Alex Walker answered
              ×

              Login

              Question stats

              • Active
              • Views3474 times
              • Answers8 answers
              • Followers1 follower